Archive for the 'IT' Category

Apr 29 2010

EyeOS 2.0 Uncaught Exception!

Published by under EyeOS,IT

Wer bei der Installation von EyeOS 2.0 folgende Fehlermeldung erhält, hat wie ich die Installationsanleitung nicht gelesen: http://www.eyeos.org/installation_manual.pdf

– Alle Dateien auf 777
– Und den Besitzer auf den Dateien ändern. Bei Plesk+OpenSuse11.1 ist das bei mir statt www-data:www-data der ftp User mit der Gruppe psalin

„Uncaught exception!

EyeErrorException: fopen(./system/conf/libs/log4php/logs/eyeos_20100429.log): failed to open stream: Permission denied
/eyeos/system/kernel/libs/log4php/appenders/LoggerAppenderFile.php (line 77) __lib_exceptions_error_handler(„./system/conf/libs/log4php/logs/eyeos_20″[..], „a“)
/eyeos/system/kernel/libs/log4php/appenders/LoggerAppenderFile.php (line 77) fopen()
/eyeos/system/kernel/libs/log4php/configurators/LoggerConfiguratorXml.php (line 399) activateOptions(resource, „APPENDER“)tagClose(resource, “
<“[..], 1)
/eyeos/system/kernel/libs/log4php/configurators/LoggerConfiguratorXml.php (line 178) xml_parse(“
<“[..], LoggerHierarchy)
/eyeos/system/kernel/libs/log4php/configurators/LoggerConfiguratorXml.php (line 154) parse(“
<“[..], LoggerHierarchy)
/eyeos/system/kernel/libs/log4php/configurators/LoggerConfiguratorXml.php (line 143) doConfigureByString(„./system/conf/libs/log4php/configuration“[..], LoggerHierarchy)
/eyeos/system/kernel/libs/log4php/configurators/LoggerConfiguratorXml.php (line 126) doConfigure(LoggerHierarchy, „./system/conf/libs/log4php/configuration“[..])
/eyeos/system/kernel/libs/log4php/Logger.php (line 623) configure()
/eyeos/system/kernel/libs/log4php/Logger.php (line 347) initialize(„system.libs.log4php“)
/eyeos/system/kernel/libs/log4php/log4php.php (line 41) getLogger()lib_log4php_load(„lib_log4php_load“)
/eyeos/system/bootstrap/Bootstrap.php (line 118) call_user_func(„log4php“)
/eyeos/system/bootstrap/Bootstrap.php (line 110) loadLibrary(array(3))
/eyeos/system/bootstrap/Bootstrap.php (line 65) loadLibraries()“

One response so far

Apr 20 2010

Plesk 9.2 + OpenSuse 11.1 = Vserver bei Strato

Published by under IT,Server

Wer sich gerade ein Vserver Paket bei Strato bucht, wundert sich wahrscheinlich, dass der vorkonfigurierte Server nicht zu erreichen ist und Plesk nicht ausgeführt werden kann. Nach einer Anfrage bei Strato bekam ich die folgende Antwort und hatte nach ca. 5 Minuten Zugriff auf Plesk:

„Sie hatten berichtet, dass auf Ihrem Server im Auslieferungszustand mit dem System openSUSE 11.1 inkl. Plesk 9.2 die Software Plesk nicht zu erreichen ist. Wir haben den Sachverhalt geprüft und mussten die Einschränkung bestätigen.
Die Ursache ist die folgende: das aktuelle openSUSE Update der Bibliothek ‚libopenssl‘ ist inkompatibel zu Plesk.
Daher besteht bis zu einem Patch des Herstellers Parallels zu seiner Software Plesk nur die Option auf die ältere (unsichere) Systembibliothek zurückzugreifen.

Die folgenden Schritte sind dazu als Nutzer ‚root‘ auf dem Server via SSH nötig=>

1.) Die entsprechende Datei aus dem Server-Repository auf Ihren Server laden:

wget ftp://ftp.stratoserver.net/pub/linux/opensuse/update/11.1/rpm/i586/libopenssl0_9_8-0.9.8h-28.13.1.i586.rpm

2.) Die Software dort installieren:

rpm -Uvh –oldpackage libopenssl0_9_8-0.9.8h-28.13.1.i586.rpm

3.) Das Plesk-Controlpanel starten:

/etc/init.d/sw-cp-server restart “

4 responses so far

« Prev